[LUGA] Mit freundlicher Unterstützung von:
WSR

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[luga] apt-get Problem (zirkel bei Abhängigkeiten)



Hallo Liste, besonders die Debianer.

Ich habe ein Problem bei apt-get: (Details im Anhang)
Ich möchte das Paket libc-client2007e installieren.

Im Endeffekt hängt es an der libc6 / ... mit der "dpkg" nicht zurechtkommt(?)

ein "apt-get update" produziert "404 Not Found" Fehler (Details:
apt-update.txt)


firix:~# vi /etc/apt/sources.list
#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST
Binary-1 20070407-11:29]/ etch contrib main

#deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST
Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.at.debian.org/debian/  lenny main
deb-src http://ftp.at.debian.org/debian/  lenny main

deb http://ftp.at.debian.org/debian/  squeeze main
deb-src http://ftp.at.debian.org/debian/  squeeze main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

deb http://people.connexer.com/~roberto/debian/ lenny main
deb-src http://people.connexer.com/~roberto/debian/ lenny main

~
~
~
~
"/etc/apt/sources.list" 17L, 682C                             12,54





für jeden Tip dankbar

Edgar



firix:~# apt-get install libc-client2007e
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Probieren Sie âapt-get -f installâ, um diese zu korrigieren:
Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
  libc-client2007e: Hängt ab: libgssapi-krb5-2 (>= 1.7dfsg~beta1) soll aber nicht installiert werden
                    Hängt ab: libk5crypto3 (>= 1.6.dfsg.2) soll aber nicht installiert werden
                    Hängt ab: libkrb5-3 (>= 1.6.dfsg.2) soll aber nicht installiert werden
                    Hängt ab: libpam0g (>= 0.99.7.1) aber 0.79-4 soll installiert werden
                    Hängt ab: libssl0.9.8 (>= 0.9.8k-1) aber 0.9.8c-4etch4 soll installiert werden
                    Hängt ab: mlock soll aber nicht installiert werden
  locales: Hängt ab: glibc-2.11-1
E: Nichterfüllte Abhängigkeiten. Versuchen Sie âapt-get -f installâ ohne jeglich Pakete (oder geben Sie eine Lösung an).
firix:~# apt-get install locales
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
locales ist schon die neueste Version.
Probieren Sie âapt-get -f installâ, um diese zu korrigieren:
Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
  locales: Hängt ab: glibc-2.11-1
E: Nichterfüllte Abhängigkeiten. Versuchen Sie âapt-get -f installâ ohne jeglich Pakete (oder geben Sie eine Lösung an).
firix:~# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Abhängigkeit werden korrigiert... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libc-bin libc6 libc6-i686
Vorgeschlagene Pakete:
  glibc-doc
Die folgenden NEUEN Pakete werden installiert:
  libc-bin
Die folgenden Pakete werden aktualisiert:
  libc6 libc6-i686
2 aktualisiert, 1 neu installiert, 0 zu entfernen und 774 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0B von 5789kB Archiven geholt werden.
Nach dem Auspacken werden 12,3kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?
Vorkonfiguration der Pakete ...
dpkg: Vor-Abhängigkeitsproblem betreffend .../libc-bin_2.11.2-10_i386.deb, welches libc-bin enthält:
 Paket verwendet »Breaks«; nicht unterstützt in dieser dpkg-Version
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb (--unpack):
 nicht unterstütztes Abhängigkeitsproblem - installiere libc-bin nicht
dpkg: Vor-Abhängigkeitsproblem betreffend .../libc6_2.11.2-10_i386.deb, welches libc6 enthält:
 Paket verwendet »Breaks«; nicht unterstützt in dieser dpkg-Version
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libc6_2.11.2-10_i386.deb (--unpack):
 nicht unterstütztes Abhängigkeitsproblem - installiere libc6 nicht
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb
 /var/cache/apt/archives/libc6_2.11.2-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
firix:~#






firix:~# apt-get update
Hole:1 http://ftp.at.debian.org lenny Release.gpg [1033B]
Hole:2 http://ftp.at.debian.org squeeze Release.gpg [1671B]
OK   http://ftp.at.debian.org lenny Release
OK   http://ftp.at.debian.org squeeze Release
Ign http://security.debian.org etch/updates Release.gpg
Ign http://ftp.at.debian.org lenny/main Packages/DiffIndex
Ign http://ftp.at.debian.org lenny/main Sources/DiffIndex
Ign http://security.debian.org etch/updates Release
Ign http://ftp.at.debian.org squeeze/main Packages/DiffIndex
Ign http://ftp.at.debian.org squeeze/main Sources/DiffIndex
OK   http://ftp.at.debian.org lenny/main Packages
OK   http://ftp.at.debian.org lenny/main Sources
OK   http://ftp.at.debian.org squeeze/main Packages
OK   http://ftp.at.debian.org squeeze/main Sources
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Ign http://security.debian.org etch/updates/main Packages
Ign http://security.debian.org etch/updates/contrib Packages
Ign http://security.debian.org etch/updates/main Sources
Ign http://security.debian.org etch/updates/contrib Sources
Fehl http://security.debian.org etch/updates/main Packages
  404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org etch/updates/contrib Packages
  404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org etch/updates/main Sources
  404 Not Found [IP: 195.20.242.89 80]
Fehl http://security.debian.org etch/updates/contrib Sources
  404 Not Found [IP: 195.20.242.89 80]
Hole:3 http://people.connexer.com lenny Release.gpg [835B]
OK   http://people.connexer.com lenny Release
Fehl http://people.connexer.com lenny Release

Hole:4 http://people.connexer.com lenny Release [8805B]
Ign http://people.connexer.com lenny Release
Ign http://people.connexer.com lenny/main Packages/DiffIndex
Ign http://people.connexer.com lenny/main Sources/DiffIndex
OK   http://people.connexer.com lenny/main Packages
OK   http://people.connexer.com lenny/main Sources
Es wurden 9642B in 11s geholt (865B/s)
Konnte http://security.debian.org/dists/etch/updates/main/binary-i386/Packages.gz nicht holen  404 Not Found [IP: 195.20.242.89 80]
Konnte http://security.debian.org/dists/etch/updates/contrib/binary-i386/Packages.gz nicht holen  404 Not Found [IP: 195.20.242.89 80]
Konnte http://security.debian.org/dists/etch/updates/main/source/Sources.gz nicht holen  404 Not Found [IP: 195.20.242.89 80]
Konnte http://security.debian.org/dists/etch/updates/contrib/source/Sources.gz nicht holen  404 Not Found [IP: 195.20.242.89 80]
Paketlisten werden gelesen... Fertig
W: GPG error: http://people.connexer.com lenny Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 2CD7785EDDA7B20F
W: Probieren Sie âapt-get updateâ, um diese Probleme zu korrigieren.
E: Einige Indexdateien konnten nicht heruntergeladen werden, sie wurden ignoriert oder alte an ihrer Stelle benutzt.
firix:~#


powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
Mrz 2011