[LUGA] Mit freundlicher Unterstützung von:
init.at

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [luga] io error bei disk



On Tue, Sep 15, 2009 at 05:12:49PM +0200, Schelling Bernhard wrote:
> Hallo,
> 
> [...was bisher geschah...]
> 
> > > > > machine#disk -l -u /dev/sdb
> > > > > Disk /dev/sdb: 2199.0 GB, 2199023255552 bytes
> > > [...]
> > > > > Device: HITACHI  HUS153030VL3800  Version: S410
> > > > [..]
> > > > Diese Platte hat nur 300GB.
> 
> > From: Hakan Evirgen [mailto:hakan@nets.at] 
> > Sent: Tuesday, September 15, 2009 8:36 AM
> 
> > IMHO sollte die Platte selber melden, wie groß sie ist. Da 
> > werden die Daten falsch vom Linuxsystem gelesen.
> > Keine Ahnung, wie man das beheben kann aber ich würde auf 
> > alle Fälle mal die ersten paar MB der Platte überschreiben 
> > (z. B. dd if=/dev/zero of=/dev/sdb bs=16k count=1000). Kann 
> > sein, daß da etwas von früher das System verwirrt.
> 
> ok hab ich gemacht, jetzt geht gar nichts mehr :)

Kein Wunder, Du hast gerade die ersten Blöcke der Platte mit 0en
überschrieben.

Nächster Schritt ist neu partitionieren (fdisk) und dann ein neues,
leeres Filesystem darauf erzeugen (mke2fs).

Wenn das geht (was ich mal vermute) solltes Du die Platte danach normal
verwenden können.

Ziel der Aktion war ja gerade, die kaputte Partition-Table (die über die
physikalische Größe der Disk hinauszeigte) loszuwerden.

Ralf
-- 
Ralf Schlatterbeck
email: ralf@zoo.priv.at FAX: +43/2243/26465/23




powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
September 2010