[LUGA] Mit freundlicher Unterstützung von:
OCG

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[luga] Sound = MIDI problem



halllo llleute,

ich hab mich mal wieder mit dem leidigen sound beschaeftigt und dabei
ein altes problem wieder ausgegraben:
auch mit dem 2.0.33'er kernel bleibt es dabei: alles funkt nur das
midi-device nicht
cat /dev/sndstat sagt so:
Sound Driver:3.5.4-960630 (Wed Jan 28 20:59:44 CET 1998 root,
Linux hospiz 2.0.33 #5 Wed Jan 28 18:54:07 CET 1998 i586 unknown)
Kernel: Linux hospiz 2.0.33 #5 Wed Jan 28 18:54:07 CET 1998 i586
Config options: 0

Installed drivers: 
Type 1: OPL-2/OPL-3 FM
Type 5: Roland MPU-401
Type 2: Sound Blaster
Type 7: SB MPU-401

Card config: 
Sound Blaster at 0x220 irq 10 drq 3,5
Roland MPU-401 at 0x330 irq 10 drq 0
(SB MPU-401 at 0x330 irq 10 drq 0)
OPL-2/OPL-3 FM at 0x388 drq 0

Audio devices:
0: ESS ES1688 AudioDrive (rev 11) 

Synth devices:
0: Yamaha OPL-3

Midi devices:

Timers:
0: System clock

Mixers:
0: Sound Blaster
--- end output >cat /dev/sndstat

und wenn ich mit xplaymidi versuche ein midi-file zu spielen dann sagt
der
Playmidi 2.2 Copyright (C) 1994-1996 Nathan I. Laredo
This is free software with ABSOLUTELY NO WARRANTY.
For details please see the file COPYING.
xplaymidi: No playback device set.  Aborting.
--- end output >xplaymidi

jetzt frag ich mal euch: woran kann das liegen?
die midi-relevanten /dev's sehen bei mir so aus:
lrwxrwxrwx   1 root     root            5 Jan 28 20:55 /dev/midi ->
midi0
crw-rw-rw-   1 root     root      14,   2 Jan 28 20:51 /dev/midi00
crw-rw-rw-   1 root     root      14,  18 Jan 28 20:51 /dev/midi01
crw-rw-rw-   1 root     root      14,  34 Jan 28 20:51 /dev/midi02
crw-rw-rw-   1 root     root      14,  50 Jan 28 20:51 /dev/midi03
crw-rw-rw-   1 root     root      14,   1 Jan 28 20:51 /dev/sequencer
lrwxrwxrwx   1 root     root           10 Oct 22 23:54 /dev/sequencer2
-> /dev/music
crw-rw-rw-   1 root     root      14,   8 Jan 28 20:51 /dev/music
{root}/[85]: cat /cdrom/midi/backing.mid > /dev/midi
{root}/[86]: cat /cdrom/midi/backing.mid > /dev/midi01
/dev/midi01: No such device or address.
{root}/[87]: cat /cdrom/midi/backing.mid > /dev/midi02
/dev/midi02: No such device or address.
{root}/[88]: cat /cdrom/midi/backing.mid > /dev/midi03
/dev/midi03: No such device or address.
{root}/[89]: cat /cdrom/midi/backing.mid > /dev/midi00
/dev/midi00: No such device or address.
{root}/[90]: cat /cdrom/midi/backing.mid > /dev/midi00
/dev/midi00: No such device or address.
{root}/[91]: cat /cdrom/midi/backing.mid > /dev/sequencer
cat: write error: No such device or address
{root}/[92]: cat /cdrom/midi/backing.mid > /dev/sequencer2
cat: write error: Invalid argument
{root}/[93]: cat /cdrom/midi/backing.mid > /dev/music 
cat: write error: Invalid argument
--- und aus

tnx for any help

ciao
-- 
Martin "Lolly" Lorenz

http://unet.univie.ac.at/~a9026080/

There is only one thing worse than Central Services...
	...Microsoft

(in a world without fences - who needs Gates ... )



powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
September 2010